Thursday, July 3, 2014

Cannot update ADT 23.0.2 because of conflicting dependency...!

Updated@2014-07-08: Fixed by re-install updated Eclipse ADT Bundle with Android SDK 20140702.



After updated Android SDK Tools 23.0.2, I cannot update ADT 23.0.2 because of a conflicting dependency.

Cannot complete the install because of a conflicting dependency.
  Software being installed: Android Hierarchy Viewer 23.0.2.1259578 (com.android.ide.eclipse.hierarchyviewer.feature.feature.group 23.0.2.1259578)
  Software currently installed: eclipse 23.0.0.1245622 (adtproduct 23.0.0.1245622)
  Only one of the following can be installed at once: 
    Hierarchy Viewer 23.0.2.1259578 (com.android.ide.eclipse.hierarchyviewer 23.0.2.1259578)
    Hierarchy Viewer 23.0.0.1245622 (com.android.ide.eclipse.hierarchyviewer 23.0.0.1245622)
  Cannot satisfy dependency:
    From: eclipse 23.0.0.1245622 (adtproduct 23.0.0.1245622)
    To: com.android.ide.eclipse.hierarchyviewer.feature.feature.group [23.0.0.1245622]
  Cannot satisfy dependency:
    From: Android Hierarchy Viewer 23.0.0.1245622 (com.android.ide.eclipse.hierarchyviewer.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.hierarchyviewer [23.0.0.1245622]
  Cannot satisfy dependency:
    From: Android Hierarchy Viewer 23.0.2.1259578 (com.android.ide.eclipse.hierarchyviewer.feature.feature.group 23.0.2.1259578)
    To: com.android.ide.eclipse.hierarchyviewer [23.0.2.1259578]


Cannot fix it! no matter how to change Software Site, un-install installed software, even re-install adt-bundle-linux-x86-20140624.zip. May be I have to wait further update from Google :(


15 comments:

Anonymous said...

Having the same issue.

Chitrang Patel said...

Please provide solution as soon as possible.

Anonymous said...

Me tooo ;-(((

Nawaz said...

I've facing EXACTLY the same issue.

evilripper said...

the same here!! :( now I will try to update eclipse from Juno - http://download.eclipse.org/releases/juno

evilripper said...

ah ok I found workaround:
https://code.google.com/p/android/issues/detail?id=72419#c12

http://stackoverflow.com/questions/24445367/error-in-adt-23-update

Now I will try but first I will copy a backup of sdk folder... :)

Andr.oid Eric said...

Updated@2014-07-08: Fixed by re-install updated Eclipse ADT Bundle with Android SDK 20140702.

Anonymous said...

I was facing the same problem I have installed it from Marketplaces in eclips

Anonymous said...

i re-installed everything but there is no Run As-Android Application Project in it.. Also many icons from toolbar are missing

pawan agarwal said...

Having the same issue.
Please provide solution as soon as possible.

Victor Mwenda said...

I had to download the lastest Android ADT and copy it over my Eclipse and SDK folders. Then all went well thereafter.

android training in chennai said...

Hi admin,

i am new to the world of mobile application development and confused with array of software development kit. please assist me in choosing the ideal one..

Srii said...

Same kind of problem I faced! Its quite disappointing.

Arjun Rishi said...

Have you found out the solution yet? If yes, please share it with us.

Vinci said...

Your blog is really awesome. Thanks for sharing this blog.